侧边栏壁纸
博主头像
乌拉队长博主等级

你只管努力,其余的交给命运

  • 累计撰写 122 篇文章
  • 累计创建 34 个标签
  • 累计收到 31 条评论

目 录CONTENT

文章目录

解决anaconda安装第三方包出现的 ERROR

乌拉队长
2020-04-05 / 0 评论 / 0 点赞 / 2,158 阅读 / 0 字

开发环境:

win10 x64

cuda10.0

anaconda4.0.0


这个报错是由于依赖包版本过高(过新)造成的。

现象还原:使用anaconda安装scikit-learn后,再安装matplotlib时报上述错误。

解决:安装的matplotlib版本太高,降低版本即可解决。

然而,这还不算完,一般使用conda命令安装的scikit-learn在导入时可能正常导入,但在使用时容易报错,(反正我是这样)

解决办法就是卸载sklearn,然后使用pip重新安装,但直接使用pip install scikit-learn 命令安装后,可能还会出错,重新安装过程

见:

解决安装sklearn后可以正常导入,但运行报错

0

评论区